Jump to content

noddy_2121

Members
  • Posts

    1,615
  • Joined

  • Last visited

About noddy_2121

  • Birthday 18/10/1982

Profile Information

  • Gender
    Male
  • Location
    Burnley
  • RC Cars
    HoBao Hyper 7 TQ | Traxxas Rustler VXL
  • How did you find this forum?
    SEARCH ENGINES
  • eBay Username
    noddy2121

Recent Profile Visitors

2,109 profile views

noddy_2121's Achievements

Contributor

Contributor (5/14)

  • Week One Done
  • One Month Later
  • One Year In
  • Piece of Furniture
  • Collaborator Rare

Recent Badges

28

Reputation

  1. Morning all, Does anyone know the official name or part number of them little plastic clips used to harden the suspension on the likes of a hyper 7? You clip them onto the suspension which causes the buggy ride height to increase and the suspension to compress. I cannot find them on the hyper 7 manual. Thank you
  2. Just find it really odd that the charger would just die!
  3. hi all, A few weeks ago, I posted on here about my lipo batteries not charging, they were showing as over voltage on my lipo charger. I thought it was the batteries that didn’t survive 2 years of no use. However, I just bought two new lipo batteries, connected them to the lipo charger and they also show over voltage! could the lipo charger be faulty? Is this common? thanks in advance
  4. Hi all, My Traxxas ID Lipo 2s battery has been away in the cupboard for a couple of years, I have a feeling I didn’t put into storage mode last time I used it. Im using a Traxxas ID Ez Peak charger. The battery will not complete a storage charge, the charger just sits one red LED and one flashing green LED. However a balance charge seems to complete ok. Any ideas why it won’t go into storage mode? My rustler isn’t working just now so I can test the battery. Any ideas please? Thanks in advance
  5. It now seems to be charging on the 2s lipo setting… after using the NiCd setting to get the cells above 3v.
  6. and how long should I leave it? Until it says charged? Then charge again on Lipo?
  7. mmmm seems to be doing something 😊
  8. I haven’t but I shall try
  9. i will plug em in and get a reading
  10. is it worth me buying a new charger rather than new batteries?
  11. Ah ok, I really hope it’s this! What can I check? Try? Please.
  12. it is yeah, iv checked and checked the settings on the overlander and defo correct. also just totally drained the batteries. Still the same 😞
  13. Hi all, Trying to charge / balance my 2s lipo batteries and getting the following error… Battery check. Over Voltage. I haven’t used the batteries for 2 years. I thought I put them in storage mode but maybe didn’t. Do I have a couple of dead lipos? If so, can anyone suggest a good replacement please? Nothing too expensive. Thanks in advance.
  14. Hi all, not posted in a while, hope everyone is well. I am trying to find the correct E-clips for this part. Hobao Hyper 8 Arm Shaft 3X44Mm 4Pcs H88014 https://www.ebay.co.uk/itm/153482095672?mkcid=16&mkevt=1&mkrid=711-127632-2357-0&ssspo=2RbBY9arR_C&sssrc=2349624&ssuid=kxt4b7e2tlo&var=&widget_ver=artemis&media=COPY Does anyone know what size E-clips I need? thank you Wayne
×
×
  • Create New...