Jump to content
  • Join our community

    Sign-up for free and join our friendly community to chat and share all things R/C!

JLB Cheetah 120A 21101 No Control Help


Recommended Posts

Hello,

I'm new to RC cars and I bought my first "serious" RC truck, it's JLB Cheetah 120A. I ordered the RC from Banggood and when it arrived during the first run I noticed there is a second delay on the throttle, brake and steering. I reported it immediately to Banggood and support doesn't care, after months of fighting with Banggood customer support I gave up. First it was just a second delay what ever I pressed on the Remote control and then with time it got worse to the point RC is completely uncontrollable and dangerous (see the video). When I turn on Remote and then RC somethimes it doesn't connect, so I have to turn it off and turn it on again, when it connects it steers to the full left and gives max trottle, when I press brake or anything else on remote it doesn't react at all. I want to fix it, so far I tried -

1 - Replacing Remote Control and receiver I bought Dumbo 6 channel remote with X6FG receiver - it did not fix the problem
2 - I reprogrammed the ESC to the default settings - no luck
3 - Calibrate neutral, trottle and brake point to ESC - again no luck

After all those attempts RC just steers to full left and gives itself max trottle, it doesn't react to anything. As you can see videos are posted last year in September, couple of days ago I took it from strorage and nothing changed, when I turn it on it steers to the left and gives full trottle. Now I suspect the ESC is the problem, but before buying anything I want to hear from experienced RC enthusiast what they would recommend.
Thank you for the help

 

 

 

 

 

 

Link to comment
Share on other sites

I did but it doesn’t react to anything - brake, trottle, left and right steering, nothing is working. And the car gives itself full trottle and steers to left when it’s connected to the remote, if it’s not connected it will not do that.

Link to comment
Share on other sites

False alarm, it’s uncontrollable again for no reason. I tried again bidding receiver, calibrated remote and checked ESC programming and everything seems to be ok, but RC refuses to work, same symptoms as before…

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...