billyupnorf

Please help with choosing the upgrade for TT01-E

41 posts in this topic

Hi guys, i am fairly new to the Rc cars, i only play with my twins boys on the front yard. I bought the Delta Lancia TT01E Last year from MSUK and it came as stock.

 

I would love your input on the upgrade options i have here,  I have already upgraded the Drive shaft, Dog bone axle and Bearing steering to the Hopup Aluminium.

 

I am now currently looking at getting a little more speed so the options i have seen on MSUK (within budget)

 

Hobbywing EZRUN Combo B9 - 5.5t 6000kV + 60A SL Waterproof (On-Road) @

Share this post


Link to post
Share on other sites

Did you fit a fit a full bearing kit as it is vital for longevity of parts.

Re the combo you linked to, I run HW kit on 2s in 2wd Tamiya without issue, on a 13t motor. 5.5t should be fine for the 4wd platform, tho you may need to play with pinion/spur gears to keep running temps down. I would recommend buying RW racing hardened steel pinions also for lipo use, the stock ones are very weak.

The ESC is lipo only, as stock, the fan will take 2s, but u need to swap it out for a bigger version to run 3s. Easy to program and set up. Bear in mind that the tamiya rally cars are meant to run at scale speeds, not set land speed records...

1 person likes this

Share this post


Link to post
Share on other sites

I wouldnt run a 5.5t in a TT01 even with upgrades, will flatten the spur and diff bevels within 2 runs. Id run a max of 9.5t for a good mix of speed and power geared to 23/58. Dont forget a good solid RW pinion.

Share this post


Link to post
Share on other sites

Thanks for your replies, I was looking at 13t motor but I think it's best to get a 8.5 high powerered now so if I did get a newer car I can use the motor. I haven't done a full bearing upgrade yet. I will need to do some research on that as I am not sure how it's done.

So going forth, I would need to do full bearing, pinion/spur 23/58 before adding the motor?

Share this post


Link to post
Share on other sites

Checklist:

Aluminium propeller shaft and cups

Full ballrace kit

Speed gear spur set

RW pinion

Aluminium motor mount.

More than ample then for a spanking.

Share this post


Link to post
Share on other sites

Thanks nutty professor, car is fully ball raced & has the smallest pinion already installed (checked with msuk) as it's xbs. Drive shaft done last week, so ordered the mount and gone for the 8.5t ezrun motor. I'll let you guys know the outcome.

Share this post


Link to post
Share on other sites

Pinion or Spur? Because it makes a massive difference to which one it is.

Share this post


Link to post
Share on other sites

I am still currently looking into the gears/spur along with battery. This is what I currently have http://www.modelsport.co.uk/?product_id=38310.

I am trying to work out if I will need lipo battery and charger. As for the gears I am not sure which setup to go with. This is the motor I have purchased http://www.modelsport.co.uk/hobbywing-ezrun-combo-b9-5.5t-6000kv-60a-sl-waterproof-on-road-/rc-car-products/376987

Any recommendations is much appreciated

Share this post


Link to post
Share on other sites

I did actually say NOT to get the 5.5t combo, it will twist the ally prop shaft and wreak your gears. You better stock up on diff parts then, you will need them.

Share this post


Link to post
Share on other sites

I didn't go for the 5.5t went for the 8.5t as you recommended above,

Share this post


Link to post
Share on other sites

Oh I see what you mean now, I had copy and pasted the wrong link above, I have definitely got the 8.5t

Share this post


Link to post
Share on other sites

have you got some better tyres yet? Better tyres are definitely needed with that combo

Share this post


Link to post
Share on other sites

HPI X Patterns are good.

Share this post


Link to post
Share on other sites

I only have the stock tyres that came with it, Looks good quality with good grip.

 

ovkh.jpg

 

I opened the car up a little more today and found the bearings are plastic, so i had changed the ones on either drive shaft,

i don't feel confident enough to opening the suspension area just incase i can't put it back together again,

 

ssk9.png

 

I also found the Spur (plastic) is 61T and pinion (metal) but not sure what size that is. 

 

obtv.jpg

 

And i believe i will need lipo 7.4v 2s Battery and charger as these will not work? am not sure if that true or not.

 

ourw.jpg

 

towj.jpg

 

I should have the Motor & Mount tomorrow so i will have a go at putting that in...

Share this post


Link to post
Share on other sites

Change all the bearings while you have it stripped, just note which way the diffs are.

Share this post


Link to post
Share on other sites

you should of got a manual with it? if so it should be in there how it comes apart etc

if not there will be a manual online somewhere as they are a very very popular kit to build.

 

 

battery wise i would not go anything over a 2s! 3s is just to much power you will not be able to go full throttle as it will spin all 4 wheels and you will crash! it spins all 4 with a 2s!

 

charger wise get this, http://www.modelsport.co.uk/core-rc-uac50-charger-12v-110-240v-6a/rc-car-products/365880

simple to use and will charge a 2s perfectly, next you need a good battery so something like this http://www.modelsport.co.uk/orion-rocket-sport-4200-lipo-25c-7.4v-uni-plug-/rc-car-products/369242

its a pricey battery but will see you good due to having multiple connectors and a good size mah

you could go to somewhere like hobbyking for a lipo they are cheaper but you will most likely have to do some soldering, plus they come in all shapes and sizes, the one from ms is the same size as a normal nimh so it will fit perfectly into a tt-01

 

also get a lipo charge bag http://www.modelsport.co.uk/overlander-lipo-safe-sack/rc-car-products/38313

 

one last thing before you get anywhere near a lipo, read these tutorials from suicideneil http://robotwars.00server.com/tutorials.html

Edited by Bonez

Share this post


Link to post
Share on other sites

Hi guys, just got the motor today along with a new shell and few other small bits. I have done the metal bearings, was easy once I had the instructions. Can anyone advise on how I am suppose to connect the gold connectors to these wires? Also for the time being I would have to use the stock battery so am guessing I will have to solder the tamiya connector to new bec?

Posted ImagePosted ImagePosted Image

Share this post


Link to post
Share on other sites

solder mate, you cant crimp or anything.

 

also you will need to change your connectors to something other than tamiya plugs, when using lipo's the tamiya connector will melt.

i suggest going for some losi EC3, really really easy to solder on.

Share this post


Link to post
Share on other sites

Thank you for that, i was not sure whether to solder it not, I will give that a go shortly. Yes I will change the tamiya connectors once I have bought a lipo battery and charger. Some have been recommended above but I will have to wait until I have some spare cash for them. The motor has slotted in nice and snug. Now the hard bit solder...Posted Image

Share this post


Link to post
Share on other sites

i would look into changing connectors asap bud! some have melted tamiya plugs using brushless with nimh!

Share this post


Link to post
Share on other sites

I have got it all soldered and connected as shown in the diagram. When I connect the battery and switch it on, the fan spins (really really fast) apart from that nothing else seems to work. I think I am missing power from the servo box as the old setup had a wire in there from the stock esc. On this one there is no extra wire to go into the servo. Any ideas what I am doing wrong here?Posted Image

Share this post


Link to post
Share on other sites

Lol I only just seen what I have done wrong in the picture. I've got it working now but I'll see if you guys can figure it out. Took me about 20-30mins

Share this post


Link to post
Share on other sites

Thanks for all your help guys, I've been out to play with the car...and crashed it. I must say it is super fast!! I definitely need some good tyres and to be honest I don't think I'll need a lipo battery? It's really really fast as it is now. This is the damage after hitting the curb. Luckily I have some spares to get it back up and running straight away.

Posted Image

Share this post


Link to post
Share on other sites

hahah plugged the plug in the wrong way ;) we've all done that at some point lol

 

umm looks exactly like the damage after the crash i had!!

 

well if you get used to the power you can then upgrade to a lipo bud but really think about changing out the tamiya plugs for something else!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.